PackageKit: Call for testing

Category: Ubuntu

The APT backend for PackageKit has made a lot of progress recently in the 0.3.x series. It nearly supports all features of PackageKit. 

Highlights of the 0.3.x series are:

  • Search for codecs and mime type handlers
  • Local file installation
  • Change log for updates
  • Group support
  • Repository handling
  • Notification of new distro releases
  • A lot of bug fixes

See the feature matrix for more infromation.

Currently we have got a quite outdated 0.2.4 version in Intrepid. Furthermore sharing the same version would help to reduce maintenance burden, since Fedora plans to ship 0.3.2 in the next release. But before proposing a freeze exception I would like to have some feedback.

So if you are interested in this piece of software and want to push packagekit forward please test it on your system and report bugs that you may encounter.

You can find packages of the upcoming 0.3.2 release for Hardy and Intrepid in this Personal Package Archive. Add the repository and install the packages packagekit and packagekit-gnome.

The new applications will appear in the System->Administration menu.

 

Update: I uploaded packages to the PPA which fix a problem with PolicyKit. Furthermore I fixed the reference to packagekit-gnome package above.

Update: I just upgraded the packages to 0.3.5 and filled a new freeze exception:

https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/276264